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Introduction 

 

Thank you for using ENGISSOL products. Our experienced scientific team can assure you that 

you will be provided with a robust, powerful and reliable application of high standards and 

guaranteed accurate results, regarding the analysis and design of any cross section (generic, 

built up of one or more geometric entities, composite etc.). ENGISSOL’s know-how with 

respect to engineering application development is incomparable, a fact that is proven by 

thousands of satisfied end-users around the world. 

Cross Section Analysis & Design performs all cross section calculation tasks. Among the 

program’s capabilities are the calculation and illustration of Moment vs. Curvature graphs, 

interaction surfaces, stain distributions as well as stress contour plots. Moreover, 

reinforcement check or design options are also supported. The application fully complies 

with all major codes for reinforced concrete sections (AASHTO, UBC, AS 3600, IS 456, ACI 

318, BS 8110, CSA A233, EC2, NZS 3101 and CP 65) but can also handle other user-defined 

materials (linear, bilinear, trilinear, parabolic or fully customized materials by providing a 

stress/strain curve). 

Cross Section Analysis & Design covers efficiently a design engineer’s everyday needs due to 

the program’s simplicity and the wide range of supported cases. 

This document contains a series of worked examples for Cross Section Analysis & Design 

which can be found in the application using the File -> Open sample project menu item. We 

have tried to include characteristic examples from an extended range of common cases in 

the field of concrete, steel and composite structures. 

At ENGISSOL we are always looking for feedback on how to improve our products. You can 

contact us at engissol@engissol.com. 

 

mailto:engissol@engissol.com
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Example 1 

 

Reinforcement design of a beam section 

Data 

The bottom required reinforcement of a beam section 25 cm x 60 cm is to be estimated. Top 

reinforcement is 3ø12. Extra side reinforcement is 2ø12. Top and side reinforcement bars 

are constant and do not need to be designed. 

Regulation: ACI 318 

Concrete (cylinder) strength: 25 MPa 

Yield stress of reinforcement steel: 500 MPa 

Reinforcement cover to rebar center: 4 cm 

Tensile concrete strength is ignored. 

Stirrup type: Tied 

Frame type: Intermediate 

All remaining data (concrete stress block, φ reduction factors, other coefficients etc.) to be 

taken according to ACI 318. 

Load cases 

lc1: N = 0  My = -250 kNm  Mz = 0 

lc2: N = 0  My = 20 kNm  Mz = 0 

lc3: N = 15 kN My = -45 kNm  Mz = 0 

lc4: N = -7 kN My = -65 kNm  Mz = 0 
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Solution with Cross Section Analysis & Design 

First of all define the corresponding Reinforced Concrete Code, by clicking on the Project -> 

Reinforced Concrete Code menu item. 

Selection of Reinforced Concrete Code 

 

Selection of ACI 318 regulation and definition of Stirrup type (Tied) and Frame type (Ordinary, 

Intermediate) 

Since the examined section does not belong to a column, we can select the “User values” 

option in the Reinforcement ratio limits box. We set a minimum ratio equal to 1.5‰ and 

keep the maximum value to 4%. Since the program is intended to handle generic cross 

sections, you should review the limits for reinforcement ratios, as they can differ depending 

on the frame elements which the examined section is assigned to. But in case of columns, 

you can keep the option “Default by code for columns”. 
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Definition of material properties 

Next, we are going to specify the material properties. 

Concrete can be specified by selecting Materials -> Concrete 

 

The Default Concrete material can be overridden by changing its properties, as shown in the 

form below. 

 

Value “Concrete strength” has been set equal to 25 MPa. The concrete is not assumed 

confined and the elasticity modulus is to be calculated according to ACI 318, so we do not 
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need to change anything else. The concrete defined here is now accessible through the 

name “C25”. Alternatively we could click the “Add new” button in order to define a new 

concrete material. 

The reinforcement can respectively be defined from the Material -> Reinforcement menu 

item. 

 

We modify the Default Reinforcement material by specifying a new name (S500) and a yield 

stress of 500 MPa. 
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Drawing the geometry 

We are now ready to draw the geometry of the cross section, by clicking the Draw -> 

Rectangle using dimensions. The center point of the rectangular section can be inserted by 

entering its coordinates (0,0) and then clicking the  button, or just by clicking on the point 

(0,0) with the mouse. Then the Length and Width values should be set to 0.25 and 0.60 

respectively. Finally, the C25 concrete should be selected for the rectangle we are drawing. 

 

After we have clicked the “OK” button, the rectangle is shown in the drawing area. 
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Before drawing the rebars, we have to make sure that a proper rebar set is available for the 

design. This can be checked by selecting Project -> Available Rebars. 

 

The rebars shown above are available in the project. This means that we can draw rebars of 

these diameters and additionally the program will only choose from these rebar sizes when 

performing a reinforcement design. 

So, we can now draw the reinforcement bars by clicking on the Draw -> Rebar Line menu 

item.  
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We can enter a value (0.04 m) for the reinforcement cover to the rebar center in the field, 

which becomes active when inserting reinforcement bars, as shown below. The program 

automatically draws help lines at the specified distance from the concrete rectangle edges 

and enables mouse snapping at their intersections. 

 

To draw the bottom rebars, we click on both green circles successively. 

 

Start and end point coordinates have been automatically filled in the corresponding form. 

The remaining properties of the bottom reinforcement can be specified, by selecting a rebar 

count (4), a material (S500) and a reinforcement size (ø20). 
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Note: The specified reinforcement (ø20) is not important at this point, since their diameter 

will be calculated by the program automatically and the required rebar will be assigned to 

them during the design procedure. 

 

After clicking the “OK” button, the lower rebars are shown in the drawing area. 

We take the same steps in order to draw the top rebars. After clicking on the top points, we 

can define the corresponding properties, as below. 

 

Note that the rebar count is now set to 3 and the reinforcement size is ø12. Moreover, the 

option “Constant size for design” has been selected, so that the rebar sizes will not change 
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during the design. After clicking the “OK” button, we can continue to draw the side 

reinforcement bars. 

 

The rebar count is now set to 2 and both s1, s2 distances to 0.15 m. The option “Constant 

size for design” is still enabled since we do not want these rebars to be re-dimensioned. 

 

In order to draw the side reinforcement bars on the right, we can take advantage of the 

replicate option. 
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First of all, we click on the reinforcement line that has been defined before in order to select 

it. 

 

The line appears now thicker with its related dimensions, which informs us that it is selected. 

In order to replicate it to the right side (16 cm to the right), we click on Edit -> Replicate 

menu item and on the “Linear” tab enter a dy distance equal to 0.17 m. 

 

After clicking “OK”, the side reinforcement on the right is shown correctly. 
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Note that the rebars have automatically been numbered. When referring to specific rebars 

(for example when reporting the reinforcement forces), these numbers will be used. 
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Review of Analysis Parameters 

We need to specify the corresponding Analysis Parameters set by clicking Analysis -> 

Analysis Parameters. We will use the default “ULS” set. All parameters related to ACI 318 

code can be found in this form. The concrete stress block is rectangular according to ACI 318, 

the tensile resistance of concrete is ignored and all remaining data have the default values 

according to the code. You can override these values by modifying any of the fields of the 

form. 
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Definition of load cases 

The load cases can be selected by clicking on the Analysis -> Reinforcement design -> Load 

cases menu item. The 4 load cases can be entered in the corresponding table. A new load 

case can be inserted by clicking the  button. We make sure that the assigned Analysis 

Parameters set to each load case is ULS. 

 

Carry out the design 

We just click Analysis -> Reinforcement design -> Analyze, to perform the reinforcement 

design procedure. 

The program asks if it should assign the calculated rebars to the existing ones. We click on 

“Yes”. 

 

Results 

The results can be obtained from the Analysis -> Reinforcement design -> Show results menu 

item. 

As we can see, the cross section is adequate and the bottom rebars have been chosen to be 

ø18. Remaining rebars (top and side reinforcement) did not change (ø12), as we previously 

checked the “Constant size for design” option. Furthermore, the calculated rebars have been 

assigned to the reinforcement bars we provided in the beginning. 
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Note: The program has calculated the required rebar sizes so that the provided 

reinforcement ratio lies between the limits specified in the Reinforced Concrete Regulation 

form. 
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Example 2 

 

Reinforcement design of a beam section with rebar size 

constraints 

Data 

In this example, we are going to see how rebar size constraints can be used for designing 

reinforced concrete cross sections, so that the calculated rebars have a predefined area 

proportion, as shown in the picture below. The used cross section is similar to that defined 

in Example 1. 

 

Demonstration of area constraint between rebars 

Let’s assume the following constraint: The area of each rebar 1, 2, 3 and 4 to the area of 7, 8 

or 9 should be equal to 1.5. We suppose that side rebars are constant ø12, as in Example 1. 

Load cases 

Same to these defined in Example 1. 

Rebars 7, 8, 9 

Rebars 1, 2, 3, 4 

Example of constraint: 
Area of rebars 1,2,3,4 = 1.5 x Area of rebars 7,8,9 

Constant size ø12, 
as in Example 1 
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Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 1. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Application of constraints 

Next, we move the mouse over the reinforcement line at the top rebars (7, 8, 9) till the 

“rebar line” text appears. 

 

After right-clicking, we select “Properties” from the menu, in order to view the properties of 

the top rebars. 
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In the corresponding form, we make sure that the option “Constant size for design” is 

unchecked and the “Grow factor” value is set to 1 and finally click OK. 

 

Proceeding respectively for the bottom rebars, we set the “Grow factor” value to 1.5. 

 

Note that the selected Reinforcement values are not important, since the reinforcement 

bars will be designed by the program. 
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Carry out the design 

We just click Analysis -> Reinforcement design -> Analyze, to perform the reinforcement 

design procedure, as in Example 1. 

The program asks if it should assign the calculated rebars to the existing ones. We click on 

“Yes”. 

 

Results 

The results can be obtained from the Analysis -> Reinforcement design -> Show results menu 

item. 

As we can see, the cross section is adequate and the bottom rebars have been chosen to be 

ø18. Top rebars are now of size ø14. But the calculated required area for reinforcement bars 

1 to 4 and 7 to 9 conforms to the applied constraint, since 2.2966 cm2 = 1.5 x 1.5311 cm2. 

Remaining rebars (side reinforcement) did not change (ø12), as their “Constant size for 

design” option has been checked (in Example 1). 

Note: The program has calculated the required rebar sizes so that the provided 

reinforcement ratio lies between the limits specified in the Reinforced Concrete Regulation 

form and also the applied constraint is valid. Furthermore, it should be noticed, that the 

constraint may not be precisely valid for the placed rebar areas as well, since the program 

chooses rebars from the available ones in project (Project -> Available Rebars menu item) 

under the condition that their area is greater than the required one. 

 

Validation of applied constraint: 
2.2966 cm2 = 1.5 x 1.5311 cm2 
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Example 3 

 

Moment vs. Curvature Curve for specific axial force levels 

Data 

The creation of Moments vs. Curvature curves using Cross Section Analysis & Design will be 

demonstrated in this example. The used cross section is similar to that defined in Example 2. 

 

Geometry of cross section 

Moment vs. Curvature diagrams data 

The Moment vs. Curvature diagram for bending about Y axis is requested for the following 

axial force values: 

 N = -1000 kN (compressive) 

 N = -500 kN (compressive) 

 N = 0 (no axial force) 
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Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 1. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Review Analysis Parameters 

We click on Analysis -> Analysis Parameters menu item to view the existing Analysis 

Parameters sets. In the “ULS” set, the concrete stress distribution is chosen to be 

rectangular, which only applies to ultimate limit states and it has to be changed since the 

Moment vs. Curvature curve will be created for all possible stress states of the section, from 

the unstressed one to its failure. 

Thus, we choose a Parabolic-Linear stress strain - curve for concrete compressive parts. All 

remaining values (factors, strains etc.) are now set according to ACI 318 regulation. By 

clicking OK the form is closed. 
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Definition of load cases 

The load cases for Moment vs. Curvature analysis can be selected by clicking on the Analysis 

-> Moment Curvature -> Load cases menu item. By clicking the  button we can add a new 

load case. The Moment curvature type is set to “Moment about y”, the Custom Angle 

(coordinate system rotation) is left to 0 and the Analysis Parameters item is changed to 

“ULS” so that we can use the parameters defined previously. 

 

In order to use specific axial forces for the analysis, we click on “Options” button and in the 

form that shows, we select the option “Alternate Axial Force”. 
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Next we enter the axial force values successively in the corresponding field at the top right 

corner of the form and click the “Add” button, so that all axial forces have been filled, as 

shown below. 

 

We can also define the slope of the second branch of the equivalent bilinearized curve here, 

but we keep this value equal to 0. This means that the calculated bilinearized curve will be 

elastic-fully plastic. We click OK to close the form. 

Carry out the analysis 

We just click Analysis -> Moment Curvature -> Analyze, to perform the Moment Curvature 

analysis. 
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Results 

The results can be obtained from the Analysis -> Moment Curvature -> Show results menu 

item. 

 

The Moments vs. Curvature diagrams for the three specified axial force levels are shown in 

the form. We note that the equivalent bilinearized curves (same color, but dashed) have also 

been calculated. These can disappear by unchecking the “Show equivalent bilinearized 

curve”. 
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The color of each curve can be controlled from the corresponding “Color” box after selecting 

the curve to modify by its axial force level. 
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Section stress distribution for a specified point on Moments vs. Curvature curve 

Assuming we would like to display the strain distribution and stress contour for a specific 

point on the diagram for the curve which refers to axial force level of -1000 kN. 

First of all we select this value from the related list as shown in the picture below. 

 

Afterwards we move the mouse over the the graph . 
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By clicking on “Show strain/stress distribution for current point”, a form is shown, which 

represents the following data: 

 Neutral axis location 

 Strain distribution 

 Equivalent force couple 

 Stress contour on the cross section area 

 Reinforcement forces 

 Stress information per material 

The form is shown below. 

Point to show 

View stress info for 
specific point 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 32 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 33 

Example 4 

 

Moment vs. Curvature Curve for specific reinforcement ratios 

Data 

Aforementioned Example 3 will be extended here, in order to have Moment vs. Curvature 

diagrams calculated for different reinforcement ratios. The used cross section is similar to 

that defined in Example 3. 

Moment vs. Curvature diagrams data 

The Moment vs. Curvature diagram for bending about Y axis is requested for the following 

reinforcement ratio values: 

 0.5% 

 1.0% 

 1.5% 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 3. 
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Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Definition of a new load case 

We click on the Analysis -> Moment Curvature -> Load cases menu item and next on the  

button in order to insert a new load case “lc 2”. Load case “lc 2” contains information 

regarding the reinforcement ratio levels used for the analysis. We change the Analysis 

Parameters to “ULS” and keep the remaining values. Afterwards, the different reinforcement 

ratio levels can be defined by clicking on the “Options” button of the “lc 2” row. 

 

On the form following that shows, we choose the “Alternate Reinforcement Ratio” option 

and provide the reinforcement ratio values on the list on the right. 

 

We click OK to close the form. 
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Carry out the analysis 

We just click Analysis -> Moment Curvature -> Analyze, to perform the Moment Curvature 

analysis. 

Results 

The results can be obtained from the Analysis -> Moment Curvature -> Show results menu 

item. On this form, we choose “lc 2” in the Load case list at its top left corner in order to 

view the results of the load case defined previously. 

 

The Moments vs. Curvature diagrams for the three specified reinforcement ratio levels are 

shown in the form. We note that the equivalent bilinearized curves (same color, but dashed) 

have also been calculated. These can disappear by unchecking the “Show equivalent 

bilinearized curve” box. 
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The color of each curve can be controlled from the corresponding “Color” box after selecting 

the curve to modify by its reinforcement ratio level. 

Note: All reinforcement size constraints are respected when a reinforcement ratio is 

calculated. Thus, the side reinforcement bars are constant and bottom reinforcement area is 

50% greater of the top ones (as they grow factor has been specified equal to 1.5). 
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Section stress distribution for a specified point on Moments vs. Curvature curve 

Assuming we would like to display the strain distribution and stress contour for a specific 

point on the diagram for the curve which refers to reinforcement ratio level of 0.015. 

First of all we select this value from the related list as shown in the picture below. 

 

Afterwards we move the mouse over the the graph. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 39 

 

 

By clicking of “Show strain/stress distribution for current point”, a form is shown, which 

represents the following data: 

 Neutral axis location 

 Strain distribution 

 Equivalent force couple 

 Stress contour on the cross section area 

 Reinforcement forces/stresses 

 Stress information per material 

The form is shown below. 

 

Point to show 

View stress info for 
specific point 
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Example 5 

 

Control of concrete cracking: Estimation of the stress at 

reinforcement (Serviceability Limit State) 

Data 

We will extend the file created in Example 2 in order to calculate the stress at each rebar 

under the loads defined below. 

As many regulations propose, the effect of cracking can be controlled by considering a 

reduced reinforcement stress which is specified by other parameters, such as allowable 

crack width, rebar diameters, rebar spacing etc. 

The concrete stress/strain curve is assumed to be linear. 

Load cases 

lc1: N = 0  My = -120 kNm  Mz = 0 

lc2: N = 0  My = 37 kNm  Mz = 0 

lc3: N = 20 kN My = -54 kNm  Mz = 0 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 2. 
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Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Review of Analysis Parameters 

We need to specify the corresponding Analysis Parameters set by clicking Analysis -> 

Analysis Parameters. We will use the default “SLS” set. The concrete stress block is linear 

and the corresponding strain values are defined according to ACI 318. Strength reduction 

factors φ do not need to be changed since we are performing an analysis in Serviceability 

Limit State (stress calculation). The concrete tensile strength is ignored. You can override 

these values by modifying any of the fields of the form. 
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Definition of load cases 

We click on the Analysis -> Deformed configuration -> Load cases menu item and next on the 

 button in order to insert a new load case under the name “lc 1”. Afterwards we fill the 

values for loads and make sure that the “SLS” Analysis Parameters set is enabled. We can 

create the remaining load cases lc 2 and lc 3 likewise. 

 

We click OK to close the form. 

Carry out the analysis 

We just click Analysis -> Deformed configuration -> Analyze, to perform the analysis. 
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Results 

The results can be obtained from the Analysis -> Deformed configuration -> Show results 

menu item. 

On this form, we choose the “lc 1” load case at the top left corner, in order to view the 

results related to the first defined load case. 

The following data can be found on this form. 

 Neutral axis location 

 Strain distribution 

 Equivalent force couple 

 Stress contour on the cross section area 

 Reinforcement forces/stresses 

 Stress information per material 

 

As we can see, the maximum stress values at reinfordcement are reported as expected for 

rebars 1 to 4 (bottom layer reinforement) and have a value of 222.72 MPa. 

By the above mentioned way, we can obtain the results for the remaining load cases “lc 2” 

and “lc 3” by changing the selected load case item at the top left corner of the results form. 
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Example 6 

 

Control of concrete cracking: Estimate the stress at 

reinforcement (Serviceability Limit State) considering concrete 

tensile strength and using a parabolic concrete curve 

Data 

We will modify the file created in Example 5 in order to re-estimate the reinforcement 

stresses, but considering the concrete tensile strength and using a Parabolic-Constant 

concrete curve for compression. 

Load cases 

As defined in Example 5. 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 5. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 
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In the popup window, we choose Yes to unlock the model. 

 

Review of Analysis Parameters 

We need to modify the previously created Analysis Parameters set “SLS” by clicking Analysis 

-> Analysis Parameters and selecting “SLS” from the list at the top left corner. 

Next, we select a Parabolic-Linear stress strain curve for compressive parts of concrete. 

Finally, in order to consider the tensile concrete strength, we select the “Linear and Drop to 

Zero” option in the tensile concrete data, as shown in the form below. 
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Definition of load cases 

The load cases do not need to be changed. 

Carry out the analysis 

We just click Analysis -> Deformed configuration -> Analyze, to perform the analysis. 

Results 

Similarly to Example 5, the results can be obtained from the Analysis -> Deformed 

configuration -> Show results menu item. 

 

We notice that the stress at rebars 1 to 4 (bottom layer rebars) is now 208.39 MPa for load 

case “lc 1”. 
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Example 7 

 

Control of concrete cracking by reducing the maximum 

reinforcement stress 

Data 

In this example, we will introduce the application of reinforcement stress limits in order to 

prevent the cracking of concrete. This option is available in the “Analysis Parameters” form. 

So, by applying the corresponding Analysis Parameters set to each analysis, the 

corresponding limits will be considered automatically. 

In this example we will apply a tensile stress limit of 180 MPa. 

Load cases 

As defined in Example 5. 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 6. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 
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In the popup window, we choose Yes to unlock the model. 

 

Review of Analysis Parameters 

We need to modify the previously created Analysis Parameters set “SLS” by clicking Analysis 

-> Analysis Parameters and selecting “SLS” from the list at the top left corner. 

At the bottom right corner of the form, we activate the option “Tensile stress limit” and 

enter the value 180 MPa. 
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Definition of load cases 

The load cases do not need to be changed. 

Carry out the analysis 

We just click Analysis -> Deformed configuration -> Analyze, to perform the analysis. 

Results 

Similarly to Example 6, the results can be obtained from the Analysis -> Deformed 

configuration -> Show results menu item. 

 

The maximum tensile stress at reinforcement was 208.39 MPa in Example 5, where no 

reinforcement limit was applied. For the same loads (lc 1), we can now see that the cross 

section is now inadequate. 
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Cross section is adequate for the remaining load cases, where apparently the developed 

reinforcement stresses are smaller than the limit of 180 MPa. 

 

Note: These limits are respected for other analysis types as well (such as Interaction diagram, 

Reinforcement design etc.) provided that such stress limits have been applied to the 

corresponding Analysis Parameters sets. 
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Example 8 

 

Reinforcement design for both Ultimate and Serviceability Limit 

States 

Data 

In this example, we will perform a reinforcement design for both Ultimate and Serviceability 

Limit States (ULS and SLS). Such procedure is very common when designing reinforced 

concrete beams, since both requirements, regarding ultimate strength and cracking due to 

service loads should be checked. 

Cross Section Analysis & Design can easily handle similar cases by modifying the default 

Analysis Parameters sets ULS and SLS. If more design situations should be considered, we 

can create new Analysis Parameters sets. 

We will start from the file created in Example 7. So materials and section geometry will not 

change. 

The additional design data are as follows: 

Concrete and 
Reinforcement data 

Ultimate Limit State (ULS) 
Serviceability Limit State 

(SLS) 

Stress/Strain 
distribution 
of concrete 

Compressive 
part 

Rectangular according to ACI 
318 

Parabolic-Constant 

Tensile part Ignored (no tensile strength) 
Yes (consider tensile 
resistance) 

Reinforcement stress limits No limits (use full strength) 
Reduce tensile strength to 
220 MPa to limit crack width 

Load cases 

Moreover, the reinforcement design procedure will take place for the following loads: 

Ultimate loads (ULS) 

lc1-ULS  N = 0  My = -140 kNm  Mz = 0 

lc2-ULS  N = 0  My = 55 kNm  Mz = 0 

lc3-ULS  N = -10 kN My = -44 kNm  Mz = 0 

Service loads (SLS) 

lc1-SLS  N = 0  My = 49 kNm  Mz = 0 

lc2-SLS  N = -3 kN My = 24 kNm  Mz = 0 
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Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 7. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Review of Analysis Parameters 

We need to modify the Analysis Parameters sets “ULS” and “SLS” to match with the design 

data provided above. This can be done by clicking Analysis -> Analysis Parameters. 

First of all, we select “ULS” from the list at the top left corner. 

 

We make sure that the compressive stress strain part of concrete is set to “Default 

rectangular by code for ULS”. Moreover, the “No Tension” should be selected for the tensile 

part of concrete. The Stress/Strain limits for reinforcement are not changed as shown in 

picture above. 
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Next, we select “SLS” from the list at the top left corner. 

 

According to the given design data, we make sure that a Parabolic-Constant concrete curve 

has been selected. The tensile part should have the option “Linear and Drop to Zero” 

selected, in order to consider the tensile resistance of concrete. Finally, we have applied a 

tensile stress limit for reinforcement equal to 220 MPa. 

We notice that the strength reduction factors are in this case equal to 1.0, since the program 

automatically adjusts them to be compatible to current design situation SLS. On the other 

hand, the default values by ACI 318 were applied for the ULS case. We click ok to close this 

form. 
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Definition of load cases 

We click on the Analysis -> Reinforcement design -> Load cases menu item to enter the load 

cases. 

 

First of all, we select all the rows and click the  icon to delete them. Afterwards, we enter 

the load cases and assign the corresponding Analysis Parameters sets, as shown below. 

 

Carry out the analysis 

We just click Analysis -> Reinforcement design -> Analyze, to perform the analysis. 
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Results 

The results can be obtained from the Analysis -> Reinforcement design -> Show results menu 

item. 

 

We note that the load case is adequate and we can see the placed reinforcement sizes.  

Notice that the most unfavourable load case is lc1-SLS, which refers to Serviceability Limit 

State. Although the loads for SLS are smaller than ULS, the reinforcement demand can 

apparently be greater, since the reinforcement stress was reduced to 220 MPa. 

Furthermore, the reinforcement size constraints applied in Example 2 are considered in this 

design as well. 

These can be verified for each load case. For instance for lc1-ULS, the needed reinforcement 

for rebars 1, 2, 3 and 4 is 0.99 cm2, whereas the reinforcement demand for rebars 5, 6 and 7 

is 0.66 cm2. The size constraint is valid since 0.99 cm2 = 1.5 x 0.66 cm2. 
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Example 9 

 

Check of user-defined reinforcement pattern in a composite 

cross section of a column 

Data 

In this example we are going to create the geometry of a composite cross section, define 

rebars and check their capacity according to Eurocode 2. 

 

Regulation: Eurocode 2 

Concrete (cylinder) strength: 20 MPa 

Yield stress of reinforcement steel: 500 MPa 

Reinforcement cover to rebar center: 4 cm 

Steel grade: Fe 360 

Tensile concrete strength is ignored. 

Stirrup type: Tied 

All remaining data (safety factors, other coefficients etc.) to be taken according to Eurocode 

2. 
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Load cases 

lc1: N = -1000 kN My = 550 kNm  Mz = 123 

lc2: N = -770 kN My = 140 kNm  Mz = -365 

Solution with Cross Section Analysis & Design 

First of all define the corresponding Reinforced Concrete Code, by clicking on the Project -> 

Reinforced Concrete Code menu item. 

Selection of Reinforced Concrete Code 

 

Selection of Eurocode 2 regulation 

The reinforcement ratio limits are to be calculated according to Eurocode 2, so we keep the 

default option checked. 
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Definition of material properties 

Next, we are going to specify the material properties. 

Concrete can be specified by selecting Materials -> Concrete 

 

The Default Concrete material can be overridden by changing its properties, as shown in the 

form below. 

 

Value “Concrete strength” has been set equal to 20 MPa. The concrete is not assumed 

confined and the elasticity modulus is to be calculated according to Eurocode 2, so we do 
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not need to change anything else. The concrete defined here is now accessible through the 

name “C20”. Alternatively we could click the “Add new” button in order to define a new 

concrete material. 

The reinforcement can respectively be defined from the Material -> Reinforcement menu 

item. 

 

We modify the Default Reinforcement material by specifying a new name (S500) and a yield 

stress of 500 MPa. 
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Finally we need to define the grade of the steel Fe 360. This steel grade can be imported 

from the library of the program by clicking on the Materials -> Import from Library menu 

item. From the top list we select “Hot Rolled Steel – European (no hardening)” in order to 

view the materials belonging to this collection. 

 

Then, we can select the first row (Fe 360) and click on “Insert selected only” button to use 

this material in our project. 
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Fe 360 steel has been imported in our project. We can view/change its properties by clicking 

on it from the list of the main form, as shown in the picture below. 

 

 

Alternatively, as Fe 360 steel is as bilinear material, it can be edited from the Materials -> 

Bilinear Materials menu item. 

 

In this form, the stress/strain curve of Fe 360 hot rolled steel is represented. We do not need 

to change anything and click OK. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 65 

Drawing the geometry 

We are now ready to draw the geometry of the cross section, by clicking the Draw -> Circle 

(2Points). 

 

First of all we make sure that material “C20” has been selected in the shown form. 

Then, we can specify the center point of the circle by entering its coordinates (0,0) and then 

clicking the  button, or just by clicking on the point (0,0) with the mouse. 

After that we need to define one point on the circle. This can be done by clicking at the point 

(0.30,0). 
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So, the circle is now defined and we can see it in the drawing area. 
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We can modify its properties by moving the mouse over it, right clicking and selecting 

“Properties” from the corresponding menu. 

 

In this way, the “Circle” form is shown and we can view/change its data. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 68 

Afterwards, we can insert a hot rolled section from the library by clicking the Draw -> 

Standard Section menu item. 

 

In this form, the collections of all sections of the library are represented. In order to insert a 

HEA-400 cross section, we select “European steel shapes” from the top list and then we 

choose the “HE400A” shape from the list below. 

 

The insertion point of the shape is selected to coincide with its centroid. 

The insertion point of the shape 

is shown in red and can change 

by clicking on other possible 

points indicated in blue. 
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We should not forget to change the material for this section to Fe 360, as illustrated below. 

 

We click OK and see that the steel shape is shown in the main drawing area. 
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Furthermore, we need to draw the rebars, which will have a circular pattern. 

But first let’s see if rebar sizes are defined. We select Project -> Available Rebars. 

 

The rebars shown above are available in the project. This means that we can draw rebars of 

these diameters and additionally the program will only choose from these rebar sizes when 

performing a reinforcement design. 

Now we are ready to draw the reinforcement bars by clicking on the Draw -> Rebar Circle 

menu item. 
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We can enter a value (0.05 m) for the reinforcement cover to the rebar center in the field, 

which becomes active when inserting reinforcement bars, as shown below. The program 

automatically draws help points at the specified distance from the concrete edges and 

enables mouse snapping. 

 

To draw the rebars, we click on (0,0) point and then on one of the available green points. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 72 

We change the rebar count to 8 and also check that the reinforcement material is “S500” 

and choose a rebar size, ø20. 

After clicking the “OK” button, the lower rebars are shown in the drawing area. 
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Review of Analysis Parameters 

We need to specify the corresponding Analysis Parameters set by clicking Analysis -> 

Analysis Parameters. We will use the default “ULS” set. All parameters related to Eurocode 

can be found in this form. The concrete stress block is rectangular according to Eurocode 2 

parameters, the tensile resistance of concrete is ignored and all remaining data have the 

default values. You can override these values by modifying any of the field of the form. 
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Definition of load cases 

The load cases can be selected by clicking on the Analysis -> Reinforcement check -> Load 

cases menu item. The 2 load cases can be entered in the corresponding table. A new load 

case can be inserted by clicking the  button. We make sure that the assigned Analysis 

Parameters set to each load case is ULS. 

 

Reinforcement check 

We just click Analysis -> Reinforcement check -> Analyze, to perform the reinforcement 

design procedure. 
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Results 

The results can be obtained from the Analysis -> Reinforcement check -> Show results menu 

item. 

As we can see, the cross section is adequate for both load cases. This form reports the 

placed reinforcement ratio (9.42 ‰) which lies between the allowable limits (2‰ – 4%) 

calculated according to Eurocode 2 specifications. 
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Example 10 

 

Creation of interaction diagram for a composite cross section of 

a column 

Data 

We will use the file created in Example 9 and create the interaction diagram according to 

Eurocode 2. 

All design data are to be taken from Example 9. 

Interaction diagram data 

Case 1:  Moment about Y axis vs. Moment about Z axis for zero axial force 

Case 2: Moment about Y axis vs. Moment about Z axis for axial force values -1000 

kN (compression) and 400 kN (tension) 

Case 3: Moment about Y axis vs. Axial force for reinforcement ratio values: 0.5%, 

1.5% and 2.5% 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 9. 
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Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 
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Review of Analysis Parameters 

We do not need to modify the previously created Analysis Parameters set “ULS”. We can 

view the assigned properties by clicking Analysis -> Analysis Parameters and selecting “ULS” 

from the list at the top left corner. 

 

We click OK, as we do not need to change anything. 
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Definition of load cases 

The load cases can be selected by clicking on the Analysis -> Interaction (as per selected R/C 

code) -> Load cases menu item. 

Case 1 

We click on the  button to add a new load case. We change the name to “Case 1” and 

select “Moment about y – Moment about z” option. The assigned Analysis Parameters set 

should be “ULS”. 
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Case 2 

We click on the  button to add the next load case and change the name to “Case 2”. We 

make sure that the option “Moment about y – Moment about z” is selected and the Analysis 

Parameters set is “ULS”. Then we click on “Options” to specify the axial force levels for the 

interaction diagram. 

 

On the form above, we select “Alternate Axial Force” in the “Variations” box on the left. 

Next, we enter at the top right corner the values -1000 and click on “Add” button. We repeat 

this step for the value 400. 

 

In this way we request the interaction diagram to be produced for both specified axial force 

levels. We click OK to close the form. 
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Case 3 

As shown before, we click on the  button to add the last load case “Case 3”. We make sure 

that the option “Axial force - Moment about y” is selected and the Analysis Parameters set is 

“ULS”. Then we click on “Options” to specify the reinforcement ratio values for the 

interaction diagram. 

We select the “Alternate Reinforcement Ratio” option and provide at the top right corner 

the values of 0.005, 0.015 and 0.025. 

 

We click ok to close the form. 
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The 3 load cases are now defined. 

 

Carry out the analysis 

We just click Analysis -> Interaction (as per selected R/C code) -> Analyze, to perform the 

analysis. 
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Results 

The requested interaction diagrams can be obtained by clicking click Analysis -> Interaction 

(as per selected R/C code) -> Show results. 

Interaction diagram for Case 1: 

We choose “Case 1” from the list at the top right corner of the form. The interaction diagram 

for Moment about Y vs. Moment about Z is shown below. 
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Interaction diagram for Case 2: 

By choosing “Case 2”, appears the same interaction diagram, but for different axial force 

levels. 
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Interaction diagram for Case 3: 

Respectively, by selecting “Case 3”, we can display the interaction diagram in terms of 

Moment about Y vs. Axial force for three different reinforcement ratio values (0.5%, 1.5% 

and 2.5%). 
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Example 11 

 

Cross sectional properties of a built-up steel section 

Data 

In this example, we will create a built-up steel section and calculate its properties. 

Steel grade: A36 Gr.36 

 

Solution with Cross Section Analysis & Design 

Setting Reinforced Concrete Code to None 

Since the cross section does not have a concrete part, we can optionally set the Reinforced 

Concrete code to “None”, in order to hide all data related to reinforced concrete analysis. 

We click on Project -> Reinforced Concrete code menu item and select “None” as below. 
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Definition of material properties 

Next, we are going to specify the material properties. 

The A36 Gr.36 steel grade can be imported from the library of the program by clicking on the 

Materials -> Import from Library menu item. From the top list we select “Hot Rolled Steel – 

US (no hardening)” in order to view the materials belonging to this collection. 
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Then, we can select the first row (A36 Gr.36) and click on “Insert selected only” button to 

use this material in our project. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 89 

A36 Gr.36 steel has been imported in our project. We can view/change its properties by 

clicking on it from the list of the main form, as shown in the picture below. 

 

Drawing the geometry 

First we will insert a standard wide flange section from the library by clicking the Draw -> 

Standard Section menu item. We select the AISC13 library in the form below. 
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After selecting AISC13 shape family, all sections belonging to it, appear in the list below. 

 

We select a W360X64 cross section. 

 

 

The insertion point of the shape is selected to coincide with its centroid. 

We should not forget to check that the assigned material is A36 Gr.36. 

The insertion point of the shape 

is shown in red and can change 

by clicking on other possible 

points indicated in blue. 
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We click OK and see that the steel shape is shown in the main drawing area. 

 

Next, we will insert a Tee section. We click again on the Draw -> Standard Section menu item 

and select the AISC13 library. We click on Tee section type, select WT155X26 and change the 

“Place at point” y value to 0.2 m. 

 

Finally we click on “Insert section” button. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 92 

 

Now we need to rotate the Tee 90o clockwise. This can be done by right clicking on it and 

then selecting “Rotate”. 
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The program asks for the center point of rotation, as the status bar shows. 
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So we click on point (0.2,-0.15). Then, in order to enter the base point for rotation, we click 

on point (0.2,0.1). No we can move the mouse to rotate the cross section interactively. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 95 

After aligning it horizontally, we can click anywhere with the mouse to fix the shape in this 

position. Following this action, we delete the initial section by right-clicking on it and 

selecting “Delete”. 
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Now we are about to move the Tee section next to the W section. 

First, we uncheck the “Snap to grid” option, from the toolbar at the bottom of the screen. 

 

In this way, we disable the “Snap to nodes” function during editing geometry. On the other 

hand, the “Snap to points” option should be checked in order to enable snapping to the 

remaining characteristic points of the section parts except for the grid points. 

In order to move the T section, we right-click on right and select “Move”. 
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Then we click at the middle point of the Tee web and move it to the middle web point of the 

W section, as shown below. 
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By left-clicking on that point, the T section is fixed in this position. 

Next we will mirror the T section about a vertical axis. This can be accomplished by right 

clicking on it and choosing “Mirror”. 

The program asks for the starting point of the mirror axis (see Status bar). We enable the 

snap option again by clicking on the “Snap to grid” item in the lower toolbar and successively 

click on points (0,-0.25) and (0,0.25). 

The geometry is now defined and the drawing screen should look like this. 

 

Calculate sectional properties 

We just click Analysis -> Inertia Data -> Analyze, to have the sectional properties computed. 
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Results 

The calculated data can be found by clicking on Analysis -> Inertia Data -> Show results menu 

item. 
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Example 12 

 

Creation of interaction diagram for a built-up steel section 

Data 

In this example we will calculate the interaction diagram of the built-up section created in 

Example 11. 

Interaction diagram data 

Case 1:  Moment about Y axis vs. Axial force 

Case 2: Moment about Y axis vs. Moment about Z axis for axial force values -750 kN 

(compression) and 900 kN (tension) 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 11. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 101 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

 

In the popup window, we choose Yes to unlock the model. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 102 

Review of Analysis Parameters 

In order to review the Analysis Parameters, we click on the Analysis -> Analysis Parameters 

menu item. The reinforced concrete related parameters are hidden, since no concrete 

regulation has been selected. We can select a material from the list on the left and modify 

the existing preferences. 

 

We do not change anything and click OK. 
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Definition of load cases 

We will use the advanced interaction analysis in this example. The other option for 

interaction analysis (as per selected R/C code) is available only when a reinforced concrete 

code has been specified. 

The load cases can be selected by clicking on the Analysis -> Interaction (advanced) -> Load 

cases menu item. 

Case 1 

We click on the  button to add a new load case. We change the name to “Case 1” and 

select “Axial force - Moment about y” option. The assigned Analysis Parameters set should 

be “ULS”. 
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Case 2 

We click on the  button to add the next load case and change the name to “Case 2”. We 

make sure that the option “Moment about y – Moment about z” is selected and the Analysis 

Parameters set is “ULS”. Then we click on “Options” to specify the axial force levels for the 

interaction diagram. 

 

On the above form, we select “Alternate Axial Force” in the “Variations” box on the left. 

Next, we enter at the top right corner the values -750 and click on “Add” button. We repeat 

this step for the value 900. 

 

In this way we request the interaction diagram to be produced for both specified axial force 

levels. We click OK to close the form. 
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The 2 load cases are now defined. 

 

Carry out the analysis 

We just click Analysis -> Interaction (advanced) -> Analyze, to perform the analysis. 
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Results 

The requested interaction diagrams can be obtained by clicking click Analysis -> Interaction 

(advanced) -> Show results. 

Interaction diagram for Case 1: 

We choose “Case 1” from the list at the top right corner of the form. The interaction diagram 

for Moment about Y vs. Axial force is shown. 
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Interaction diagram for Case 2: 

By choosing “Case 2”, the corresponding interaction diagrams in terms of Moment about Y 

axis vs. Moment about Z are shown. 
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Example 13 

 

Estimation of maximum and minimum developed stresses on a 

built-up steel section under given external loads 

Data 

In this example we will calculate the stresses developed in the cross section discussed in 

Example 11 and create corresponding stress contours. 

The partial safety factor for steel is assumed to be 1.0. 

Load cases 

lc1: N = 500 kN My = 150 kNm  Mz = 100 kNm 

lc2: N = 0  My = -250 kNm  Mz = 50 kNm 

lc3: N = -200 kN My = 0 kNm  Mz = -147 kNm 

Solution with Cross Section Analysis & Design 

Opening a file from disk 

First of all we click on the File menu and select Open in order to open the file we created in 

Example 11. 

Unlock the model 

Afterwards, if the model is locked, we click on Edit -> Unlock model, in order to modify the 

geometry of the cross section. 

In the popup window, we choose Yes to unlock the model. 
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Review of Analysis Parameters 

The partial safety factor of the steel A36 Gr.36 is set to 1, so we do not need to change 

anything in the form below. We click OK to close the form. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 110 

Definition of load cases 

First we will define the load cases by clicking on the Analysis -> Deformed configuration -> 

Load cases menu item. 

The load cases can be defined by successively clicking on the  button. We have to make 

sure that the “ULS” Analysis Parameters set have been assigned to each load case. 

 

Carry out the analysis 

We just click Analysis -> Deformed configuration -> Analyze, to perform the analysis. 
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Results 

The requested interaction diagrams can be obtained by clicking click Analysis -> Interaction 

(advanced) -> Show results. 

Results for load case lc1: 

We choose “lc1” from the list at the top right corner of the form. The corresponding strain 

distribution and stress contour are shown. Moreover, information about the 

maximum/minimum stresses developed on the section can be found on the right. 
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Results for load case lc2: 

Respectively, by selecting “lc2”, appears the corresponding information for the second load 

case. 
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Results for load case lc3: 

Respectively, by selecting “lc3”, appears the corresponding information for the second load 

case. 

 

As we can see, the maximum stress is developed for load case “lc2” and has a value of 

248.21 MPa. The minimum stress is -248.21 MPa for “lc2” as well. 

Since this stress is equal to the yield of A36 Gr.36, we can conclude that some parts of the 

cross section have entered the plastic region. 
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Example 14 

 

Check of a timber cross section 

Data 

In this example, we are about to draw a timber cross section and check its adequacy under 

given external loads. 

Wood grade: C20 solid wood, according to EN 338 

Partial safety factor for solid timber: 1.3 

 

Load cases 

lc1: N = 5 kN My = 14 kNm  Mz = 0 kNm 

lc2: N = 0  My = -15 kNm  Mz = 0 kNm 

lc3: N = -5 kN My = 4   Mz = 3 kNm 
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Solution with Cross Section Analysis & Design 

Setting Reinforced Concrete Code to None 

Since the cross section does not have a concrete part, we can optionally set the Reinforced 

Concrete code to “None”, in order to hide all data related to reinforced concrete analysis. 

We click on Project -> Reinforced Concrete code menu item and select “None” as below. 

 

Definition of material properties 

Next, we are going to specify the material properties. 

The C20 solid wood grade can be imported from the library of the program by clicking on the 

Materials -> Import from Library menu item. From the top list we select “Timber – EN 338 

Solid wood” in order to view the materials belonging to this collection. 
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Then, we can select the property C20 and click on “Insert selected only” button to use this 

material in our project. 
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C20 wood has been imported in our project. We can view/change its properties by clicking 

on it from the list of the main form, as shown in the picture below. 

 

 

Drawing the geometry 

First we will draw the web of the Tee section. To do this, we click on Draw -> Rectangle using 

dimensions from the top menu. 

The center point of the rectangular section can be inserted by entering its coordinates (0,0) 

and then clicking the  button, or just by clicking on the point (0,0) with the mouse. Then 

the Length and Width values should be set to 0.08 and 0.15 respectively. Finally, the 

material C20 should be selected for the rectangle we are drawing. 
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The web should now appear in the drawing area. 

 

Next, we can draw the top flange by using the same command (Draw -> Rectangle using 

dimensions). 

On the forms that shows, we enter the coordinates of the top flange center (0,0.105) and 

click the  button. Then we specify the values for length and width and click OK. 

 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 119 

The cross section is shown in the drawing screen as follows. 

 

Finally, we repeat the last action to draw the bottom flange. 
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After clicking OK, we can see the final geometry of the cross section in the drawing area. 
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Review of Analysis Parameters 

In order to review the Analysis Parameters, we click on the Analysis -> Analysis Parameters 

menu item. The reinforced concrete related parameters are hidden, since no concrete 

regulation has been selected. 

While the “ULS” set is active, we select the C20 wood grade from the list on the left and 

change the partial safety factor to 1.3 as shown in the picture below. 

 

We click OK to close the form. 
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Definition of load cases 

We will first define the load cases by clicking on the Analysis -> Deformed configuration -> 

Load cases menu item. 

The load cases can be defined by successively clicking on the  button. We have to make 

sure that the “ULS” Analysis Parameters set have been assigned to each load case. 

 

Carry out the analysis 

We just click Analysis -> Deformed configuration -> Analyze, to perform the analysis. 
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Results 

The calculated data can be found by clicking on Analysis -> Deformed configuration -> Show 

results menu item. 

Results for load case lc1: 

We choose “lc1” from the list at the top right corner of the form. The corresponding strain 

distribution and stress contour are shown. Moreover, information about the 

maximum/minimum stresses developed on the section can be found on the right. 

 

Design for load case lc1: adequate 

Maximum stress: 6.95 MPa at point (0.1,0.135) 

Minimum stress: -7.89 MPa at point (-0.075,-0.135) 
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Results for load case lc2: 

Respectively, by selecting “lc2”, appears the corresponding information for the second load 

case. 

 

Design for load case lc2: adequate 

Maximum stress: 8.43 MPa at point (-0.075,-0.135) 

Minimum stress: -7.31 MPa at point (0.1,0.135) 
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Results for load case lc3: 

Respectively, by selecting “lc3”, appears the corresponding information for the second load 

case. 

 

Design for load case lc3: adequate 

Maximum stress: 6.56 MPa at point (0.1,0.135) 

Minimum stress: -5.98 MPa at point (-0.075,-0.135) 
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Example 15 

 

Steel jacketing for improvement of column strength and 

ductility 

Data 

In this example we are going to assess the behavior of a concrete column, after it is 

retrofitted with a 5mm thick metal jacket. So, we will create the Moment vs. Curvature 

curves before and after the jacket application. 

Concrete grade: C16/20, according to Eurocode 2 

Reinforcement grade: S400, according to Eurocode 2 

Concrete stress/strain curve: according to Eurocode 

Steel jacket grade: Fe 430, according to Eurocode 3 with a safety factor of 1.15 

Confinement options for jacketed column 

Compressive strength:   21 MPa 

Compressive strain at maximum stress: -3‰ 

Ultimate strain:    -7‰ 
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Solution with Cross Section Analysis & Design 

First of all define the corresponding Reinforced Concrete Code, by clicking on the Project -> 

Reinforced Concrete Code menu item. 

Selection of Reinforced Concrete Code 

 

Selection of Eurocode 2 regulation 

Definition of material properties 

Next, we are going to specify the material properties. 

Concrete can be specified by selecting Materials -> Concrete 
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We click on “From library” button to import an existing concrete material from the database 

of the program. 

 

After choosing the European standard, we select the C16/20 material and click the “Insert 

selected only” button. 
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Since the material has been defined, we click OK to close the form. 
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The reinforcement can respectively be defined from the Material -> Reinforcement menu 

item. As before, we click the “From library” button to select from the existing predefined 

reinforcement materials. 

 

We choose the S400 grade from the European standard and click on “Insert selected only”. 
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The reinforcement grade S400 is now available in the project. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 132 

Drawing the geometry 

We are now ready to draw the geometry of the cross section, by clicking the Draw -> 

Rectangle using dimensions. The center point of the rectangular section can be inserted by 

entering its coordinates (0,0) and then clicking the  button, or just by clicking on the point 

(0,0) with the mouse. Then the Length and Width values should both be set to 0.40. Finally, 

the C16/20 concrete should be selected for the rectangle we are drawing. 
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After we have clicked the “OK” button, the rectangle is shown in the drawing area. 

 

Before drawing the rebars, we have to make sure that a proper rebar set is available for the 

design. This can be checked by selecting Project -> Available Rebars. 
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The rebars that are shown above are available in the project. This means that we can draw 

rebars of these diameters and additionally the program will only choose from these rebar 

sizes when performing a reinforcement design. 

So, we can now draw the reinforcement bars by clicking on the Draw -> Rebar Rectangle 

menu item.  

We can enter a value (0.04 m) for the reinforcement cover to the rebar center in the field, 

which becomes active when inserting reinforcement bars, as shown below. The program 

automatically draws help lines at the specified distance from the concrete rectangle edges 

and enables mouse snapping at their intersections. 
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To draw the bottom rebars, we click on the green points at the top left and at the bottom 

right successively. 
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Next, as shown on the form below, we choose to use ø20 and ø16 rebar sizes for the corner 

and remaining rebars respectively. The rebar count (apart from the rebars at the corners) 

horizontally and vertically is set to 2.  

 

Moreover, the S400 reinforcement material is selected. 
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After clicking the “OK” button, the rebars are shown in the drawing area. 
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Behavior assessment of the cross section 

First we are going to assess the behavior of the cross section by calculating a Moment vs. 

Curvature diagram for different axial force levels. 

Review of Analysis Parameters 

We need to specify the corresponding Analysis Parameters set by clicking Analysis -> 

Analysis Parameters. We will use the default “ULS” set. 

 

The option “Default rectangular by code for ULS” for the compressive parts of concrete 

stress/strain curve cannot be used, since we are about to perform a Moment Curvature 

analysis. “Default rectangular by code for ULS” option is only valid for designing or checking 

the capacity of a cross section. 

So we choose the option “Parabolic-Linear”. The strain data have already been set by the 

program to their default values according to Eurocode 2. 

All parameters related to Eurocode 2 can be found in this form, including partial safety 

factors etc. 
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The reinforcement bars are chosen to have a bilinear behavior. A hardening of 1.15 is 

assumed. 

Additionally, we check the “Ignore compression part” in order to ignore the contribution of 

the reinforcement to the sectional resistance, i.e. steel reinforcement will only be active if it 

is under tension. This assumption is common, especially when retrofitting damaged concrete 

elements, as the sparse stirrups will not provide a lateral support to vertical reinforcement 

bars. Consequently their compressive resistance cannot be used due to buckling. 

We click OK to close this form. 

Definition of load cases 

The load cases for Moment vs. Curvature analysis can be selected by clicking on the Analysis 

-> Moment Curvature -> Load cases menu item. By clicking the  button we can add a new 

load case. The Moment curvature type is set to “Moment about y”, the Custom Angle 

(coordinate system rotation) remains 0 and the Analysis Parameters item is changed to 

“ULS” in order to use the parameters defined previously. 
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In order to use specific axial forces for the analysis, we click on “Options” button and as 

shown on the form below, we select the option “Alternate Axial Force”. 

 

Next we enter the axial force values successively in the corresponding field at the top right 

corner of the form and click the “Add” button, so that all axial forces have been filled, as 

shown below. 

 

We can also define the slope of the second branch of the equivalent bilinearized curve here, 

but we keep this value equal to 0. This means that the calculated bilinearized curve will be 

elastic-fully plastic. We click OK to close the form. 
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Carry out the analysis 

We just click Analysis -> Moment Curvature -> Analyze, to perform the reinforcement design 

procedure. 

Results 

The calculated Moment – Curvature curves for the specified axial force levels can be found 

by clicking Analysis -> Moment Curvature -> Show results. 
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Behavior assessment after the application of steel jacket 

Definition of a steel material 

The steel grade of the jacket is assumed to be Fe 430. This steel grade can be imported from 

the library by clicking on the Materials -> Import from Library menu item. From the top list 

we select “Hot Rolled Steel – European (no hardening)” in order view the materials 

belonging to this collection. 

 

Then, we can select the corresponding row (Fe 430) and click on “Insert selected only” 

button to use this material in our project. 
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Drawing the steel jacket 

The simplest way to draw the steel jacket geometry is to use the Draw -> Polygon from line 

offset. 

 

In the form that appears, we select the third option in the box “Method”. This will enable 

the drawing of the steel jacketing by just providing a path of points which are the 4 corners 

of the cross section. The specified thickness is set to 5 mm (0.005m) and current material is 

Fe 430. 

 

After successively clicking on the 4 corners of the cross section, we right-click at any point 

and choose “Close polygon” from the menu as shown above. 



  Cross Section Analysis & Design  Worked examples 

  http://www.engissol.com/cross-section-analysis-design.html 144 

 

The retrofitted column section has been now defined. We can continue by reviewing the 

used Analysis Parameters set “ULS”. 

Informing the program that the concrete is confined 

This can be easily carried out by clicking the Materials -> Concrete menu item and checking 

the “Confined” option for C16/20 concrete grade, as shown below. 
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In this way, the program will handle the C16/20 concrete as defined, i.e. the confinement 

factors specified in Analysis Parameters will be applied to this material. 

Review of Analysis Parameters 

The Analysis Parameters set “ULS” will be modified in order to simulate the effect of steel 

jacketing on the behavior of the section. 

Since the existing concrete is assumed confined, we can define the related amplification 

factors for its strength, the strain that corresponds to its strength and its ultimate strain. 

These values can be calculated according to any regulation or theoretical method and can be 

applied in the program. 

 

Example of confined and unconfined concrete stress/strain curves 

In this example we will assume that the confined concrete stress is 21 MPa, with a 

corresponding strain of -3‰ and its ultimate strain is -7‰. 

Consequently, the amplification factors can be calculated as follows: 

 Concrete strength factor: 21 MPa / 16 MPa = 1.31 

 ec2 factor:   3‰ / 2‰  = 1.5 

 ecu factor:   7‰ / 3.5‰  = 2 
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All remaining data regarding concrete and reinforcement do not need to be modified. 
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Furthermore, in tab “Other Materials data”, we can define a partial safety factor for the 

steel jacketing, which is taken as 1.15. 

 

We click OK to close this form. 

Carry out the analysis of the retrofitted section 

We just click Analysis -> Moment Curvature -> Analyze, to perform the reinforcement design 

procedure. 
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Results 

The calculated Moment – Curvature curves for the specified axial force levels can be found 

by clicking Analysis -> Moment Curvature -> Show results. 

 

As expected, after the application of the steel jacket, the cross section behavior in terms of 

stiffness, resistance and ductility has dramatically been improved. 

By clicking the “Export current graph data”, we can export the points of selected diagram to 

a text file and use them in other applications, such as Excel. In the following graph, the 

Moment vs. Curvature curves before and after the retrofit are shown for the same axial 

force load (-500 kN). 
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